Get WIN 500 € Crypto Voucher !

Incident Report for BTCvoucher.io

Update

GET WIN CRYPTO VOUCHER
Posted Apr 11, 2023 - 12:26 CEST

Monitoring

Just a few simple steps and you can be in the draw every month...

Competition conditions:
1. Add your email to subscribe to the newsletter https://bitcoinmat.org/Help_center#newsletter

2. Register with the same email on this platform.
https://bitcoinmat.org/register

3. Use your email from registration when redeeming the voucher.
https://btcvoucher.io/

4. Only vouchers redeemed in a given month will be included in the draw.

5. We will publish the winners of the draw on our Facebook page.
https://www.facebook.com/profile.php?id=100088575343755

6. After the draw, it will be checked whether the e-mail has been subscribed to the newsletter and registered on the platform. If not, the draw is repeated

7. The condition of the competition is the purchase of a voucher of any value and its use. Each redeemed voucher (except for the €1 promo voucher) is included in the draw in that month. You can find the option of ordering a voucher here or at our partners.

8. During the 10 months, there will always be a raffle for a €50 voucher. The winner will be contacted based on the registered email upon application and the prize will be delivered by courier or email.
Posted Apr 11, 2023 - 12:24 CEST
This incident affects: BTCvoucher - Exchange.